IHD Ordering Delay

Incident Report for Vetspire Status Page

Resolved

This incident has been resolved.
Posted Jan 20, 2026 - 07:11 EST

Monitoring

Per Idexx, delays in IHD orders are recovering and they are monitoring the recovery.
Posted Jan 19, 2026 - 11:22 EST

Investigating

Idexx is currently experiencing delays related to submitting an in house diagnostic order. Please reach out to them with any questions.
Posted Jan 19, 2026 - 11:05 EST
This incident affected: Labs (Third-Party Integrations) (IDEXX VetConnectPlus & In-House Labs).